intelligence_type Table

表信息 SpDevelop

intelligence_type 情报类型

intelligence_type

属于模块:aaaaaa

[表空间] jc_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | 主键 | VarChar(36) | 是 | 否 |  |  |
普通字段 type_name | 分类名称 | VarChar(255) | 否 | 是 |  |  |
普通字段 type_code | 分类编码 | VarChar(255) | 否 | 是 |  |  |
普通字段 type_desc | 分类描述 | VarChar(255) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


TabContactPerson Table

表信息 SpDevelop

TabContactPerson 联系人

TabContactPerson

属于模块:MD

                [表空间]
[表所有者]
[备注]
                xFlag 0： 供应商 1客户

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 ID |  | Integer | 是 | 否 | (1,1) |  |
普通字段 ClientId | 客户编号 | VarChar(50) | 否 | 是 |  |  |
普通字段 ManName | 姓名 | VarChar(50) | 否 | 是 |  |  |
普通字段 Sex | 性别 | VarChar(10) | 否 | 是 |  |  |
普通字段 OrgName | 部门 | VarChar(50) | 否 | 是 |  |  |
普通字段 ZwName | 职位 | VarChar(50) | 否 | 是 |  |  |
普通字段 Phone | 手机 | VarChar(50) | 否 | 是 |  |  |
普通字段 Tel1 | 电话1 | VarChar(50) | 否 | 是 |  |  |
普通字段 Tel2 | 电话2 | VarChar(50) | 否 | 是 |  |  |
普通字段 Fax | 传真 | VarChar(10) | 否 | 是 |  |  |
普通字段 Email | Email | VarChar(50) | 否 | 是 |  |  |
普通字段 QQ | QQ | VarChar(50) | 否 | 是 |  |  |
普通字段 MSN | MSN | VarChar(50) | 否 | 是 |  |  |
普通字段 Birthday | 生日 | Datetime | 否 | 是 |  |  |
普通字段 Hobby | 爱好 | VarChar(50) | 否 | 是 |  |  |
普通字段 Remark1 | 备注 | VarChar(150) | 否 | 是 |  |  | 0: 供应商 1： 客户
普通字段 XFlag |  | Integer | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


monitor_models Table

表信息 SpDevelop

monitor_models 综合监控模型

monitor_models

属于模块:AI

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | VarChar(50) | 是 | 否 |  |  |
普通字段 model_code | 模型编号 | VarChar(50) | 否 | 是 |  |  |
普通字段 model_name | 模型名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 remark | 备注 | VarChar(50) | 否 | 是 |  |  |
普通字段 device_id | 默认设备 | VarChar(50) | 否 | 是 |  |  |
普通字段 device1_id | 设备1 | VarChar(50) | 否 | 是 |  |  |
普通字段 device2_id | 设备2 | VarChar(50) | 否 | 是 |  |  |
普通字段 device3_id | 设备3 | VarChar(50) | 否 | 是 |  |  |
普通字段 area_data | 监控区域数据 | Text | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


ms_union_target Table

表信息 SpDevelop

ms_union_target 融合目标信息格式

ms_union_target

属于模块:TargetInfos

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(50) | 是 | 否 |  |  |
普通字段 device_owner_id | 设备所属站点ID | VarChar(50) | 否 | 否 |  |  | 前端站、各级监控中心
普通字段 target_id | 目标批号 | VarChar(50) | 否 | 否 |  |  | 原则上不能重复
普通字段 mmsi | Mmsi号 | VarChar(50) | 否 | 否 |  |  |
普通字段 status | 目标状态 | Integer | 否 | 是 |  |  | // = 1 正常 // = 2 预测 // = 3 丢失
普通字段 geo_ptn | 经纬度 | VarChar(255) | 否 | 是 |  |  | double latitude = 1; //纬度 double longitude = 2; //经度 wgs84坐标系，精度为0.00000001度
普通字段 course | 航向 | Double | 否 | 是 |  |  | 精度为0.01度
普通字段 speed | 速度 | Double | 否 | 是 |  |  | 精度为0.01节
普通字段 heading | 艏向 | Double | 否 | 是 |  |  | 精度为0.01度
普通字段 length | 估算目标长度 | Double | 否 | 是 |  |  | 精度为1米
普通字段 wid | 估算目标宽度 | Integer | 否 | 是 |  |  | 精度为1米
普通字段 shiptype | AIS船舶类型 | Integer | 否 | 是 |  |  | AIS船舶类型
普通字段 sclass | 枚举船舶类型 | VarChar(255) | 否 | 是 |  |  | AIS_A=0; //AIS A类型 AIS_B=1; //AIS B类型 RADAR=2; //雷达类型 SIM=3; //模拟目标类型 NORMAL_AIS_A_RADAR=4; //正常AIS A目标和雷达目标融合后的类型 NORMAL_AIS_B_RADAR=5; //正常AIS B目标和雷达目标融合后的类型 LOST_AIS_A_RADAR=6; //AIS A信号丢失的目标和雷达目标融合后的类型 LOST_AIS_B_RADAR=7; //AIS B信号丢失的目标和雷达目标融合后的类型 SIM_RADAR=8; //模拟目标和雷达目标融合后的类型 AID=9; //助航物类型 STATIC=10; //静态目标类型
普通字段 vessel_name | 船名 | VarChar(255) | 否 | 是 |  |  |
普通字段 vendor_id | 建造方ID | VarChar(255) | 否 | 是 |  |  |
普通字段 call_sign | 呼号 | VarChar(255) | 否 | 是 |  |  |
普通字段 imo | IMO | Integer | 否 | 是 |  |  |
普通字段 last_tm | 目标从服务器发送时间 | Datetime | 否 | 是 |  |  |
普通字段 ais_ext_infos | AisExt | VarChar(255) | 否 | 是 |  |  |
普通字段 src_num | 融合来源个数 | Integer | 否 | 是 |  |  | 融合来源个数
普通字段 src_index | 来源索引 | Integer | 否 | 是 |  |  |
普通字段 src_type | 来源类型 | Integer | 否 | 是 |  |  | 1-雷达，2-AIS，3-融合，4-北斗，5-GPS，6-其它
普通字段 src_site_id | 目标来源设备的所属站点ID | VarChar(255) | 否 | 是 |  |  | 目标来源设备的所属站点ID
普通字段 src_device_id | 目标来源设备的ID | VarChar(255) | 否 | 是 |  |  |
普通字段 Src_target_key | 目标来源ais时为mmsi | VarChar(255) | 否 | 是 |  |  | 雷达时为批号，融合时为新的ID号...

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


DeviceManger.db Module

模块信息 SpDevelop

DeviceManger.db

表

表名 | 中文表名
device_info | 设备借口信息格式
device_status | 设备状态信息
deveice_type | 设备类型表
camera_setting | 相机信息表
camera_linkage | 相机联动信息配置表
deveice_protocol_type | 设备通讯协议表
device_sensor_info | 设备传感器表
camera_linkage_sub | 相机联动信息配置子表

视图

视图名 中文视图名

外部表

表名 中文表名 所属模块


device_info Table

表信息 SpDevelop

device_info 设备借口信息格式

device_info

属于模块:DeviceManger

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | 设备唯一标识 | VarChar(50) | 是 | 否 |  |  | CUID字符串
普通字段 device_owner_id | 设备所属站点ID | Integer | 否 | 否 |  |  |
普通字段 device_type | 设备类型 | Integer | 否 | 否 |  |  | enum{雷达=1;AIS设备=2;白光=3;红外=4;白光红外一体=5;无人机=6;无人艇=7;周界=8;传感器=9;其他=10;}
普通字段 device_code | 设备编码 | VarChar(55) | 否 | 是 |  |  | 雷达设备编码
普通字段 device_name | 设备名称 | VarChar(255) | 否 | 否 |  |  | 例如：CP1103便携相控阵雷达
普通字段 device_position | 位置描述置 | VarChar(255) | 否 | 否 |  |  | 例如：背仔角站点
普通字段 device_lon | 设备经度 | Double | 否 | 否 |  |  | 小数点后6位，113.337664
普通字段 device_lat | 设备纬度 | Double | 否 | 否 |  |  | 小数点后6位，22.597240
普通字段 device_alt | 设备海拔 | Double | 否 | 否 |  |  | 小数点后2位，71.45
普通字段 device_status | 设备状态 | Integer | 否 | 否 |  |  | 0：在线，正常工作；1：离线，设备关机；2：在线，设备故障；3，其它；
普通字段 device_url | 设备访问路径 | VarChar(255) | 否 | 否 |  |  | 如果是雷达/AIS设备，则为设备IP地址，如果是远程光点，则为光电视频流访问地址（rtsp，例如：rtsp://username:password@ip:port/Streaming/Channels/201?transportmode=unicast）
普通字段 device_ip | 设备ip地址 | VarChar(50) | 否 | 是 |  |  |
普通字段 ip_port | 端口 | Integer | 否 | 是 |  |  |
普通字段 ip_port2 | 端口2 | Integer | 否 | 是 |  |  |
普通字段 username | 用户名 | VarChar(50) | 否 | 是 |  |  | 0：在线，正常工作；1：离线，设备关机；2：在线，设备故障；3，其它
普通字段 password | 密码 | VarChar(50) | 否 | 是 |  |  |
普通字段 subtype | 设备子类型 | Integer | 否 | 是 |  |  | 新增
普通字段 device_height | 安装高度 | Integer | 否 | 是 |  |  | 新增
普通字段 init_azimuth | 初始方位角 | Integer | 否 | 是 |  |  | 正北0度，顺时针
普通字段 init_pitch | 初始俯仰角 | Integer | 否 | 是 |  |  | 水平为0度正北0度，顺时针
普通字段 working_radius | 工作半径 | Integer | 否 | 是 |  |  | 米
普通字段 horizontal_angle | 水平市场角度 | Integer | 否 | 是 |  |  | 度默认左右对称 中线夹角，总角需要乘以2
普通字段 vertical_angle | 锤子市场角度 | Integer | 否 | 是 |  |  | 度度默认上下对称
普通字段 identification_scale | 识别刻度 | Integer | 否 | 是 |  |  |
普通字段 remark | 备注 | VarChar(50) | 否 | 是 |  |  |
普通字段 protocol | 协议类型 | Integer | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


camera_screenshots Table

表信息 SpDevelop

camera_screenshots 相机抓拍图片（手动）

camera_screenshots

属于模块:TargetInfos

[表空间] ms_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(36) | 是 | 否 |  |  |
普通字段 create_by | 创建人 | VarChar(50) | 否 | 否 |  |  |
普通字段 create_time | 创建日期 | Datetime | 否 | 否 |  |  |
普通字段 update_by | 更新人 | VarChar(50) | 否 | 否 |  |  |
普通字段 update_time | 更新日期 | Datetime | 否 | 否 |  |  |
普通字段 camera_id | 相机ID | VarChar(36) | 否 | 否 |  |  |
普通字段 camera_name | 相机名称 | VarChar(200) | 否 | 否 |  |  |
普通字段 img_url | 图片路径 | VarChar(200) | 否 | 否 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


event_level Table

表信息 SpDevelop

event_level 事件等级

event_level

属于模块:aaaaaa

[表空间] jc_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | 主键 | VarChar(36) | 是 | 否 |  |  |
普通字段 level_name | 分级名字 | VarChar(255) | 否 | 是 |  |  |
普通字段 level_code | 分级编码 | VarChar(255) | 否 | 是 |  |  |
普通字段 level_principle | 分级原则 | VarChar(255) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


node_info Table

表信息 SpDevelop

node_info 设备表

node_info

属于模块:iot

[表空间] iot_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | Integer | 是 | 否 | (1,1) |  |
普通字段 name | 名称 | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


CodeValue Table

表信息 SpDevelop

CodeValue

CodeValue

属于模块:MD

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 Id |  | Integer | 是 | 否 | (1,1) |  |
普通字段 TypeId |  | Integer | 否 | 是 |  |  |
普通字段 Code |  | VarChar(50) | 否 | 是 |  |  |
普通字段 KeyValue |  | VarChar(50) | 否 | 是 |  |  |
普通字段 Remark |  | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


radar_target Table

表信息 SpDevelop

radar_target 雷达目标信息格式

radar_target

属于模块:Interface

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 device_id | 设备ID | VarChar(50) | 是 | 否 |  |  |
普通字段 device_owner_id | 设备所属站点ID | Integer | 否 | 否 |  |  |
普通字段 target_id | 目标批号 | Integer | 否 | 否 |  |  | 原则上不能重复
普通字段 counter | 目标消息 | Integer | 否 | 否 |  |  | 从0开始的计数，从发现目标后每轮周期加1，等同于该目标的跟踪时间，精度为1
普通字段 timeout_to_next | 超时等待时间 | Integer | 否 | 否 |  |  | 通常为2个天线周扫时长，精度为1ms
普通字段 status | 目标状态 | Integer | 否 | 否 |  |  | // = 0 无效/异常 // = 1 正常 // = 2 预测 // = 3 丢失
普通字段 type | 目标类型 | Integer | 否 | 否 |  |  | //0x01 – 常规目标 //0x02 – 固定/静态目标 //0x04 – 陆地 //0x08 – 其它
普通字段 speed | 速度 | Double | 否 | 否 |  |  | 精度为0.01节
普通字段 course | 航向 | Double | 否 | 否 |  |  | 精度为0.01度
普通字段 longitude | 经度 | Double | 否 | 否 |  |  | 精度为0.00000001度，wgs84坐标系
普通字段 latitude | 纬度 | Double | 否 | 否 |  |  | 精度为0.00000001度，wgs84坐标系
普通字段 size | 估算目标长度 | Integer | 否 | 否 |  |  | 精度1米
普通字段 time | 发送时间戳 | Timestamp | 否 | 否 |  |  | 时间为UTC，精度1毫秒

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


ms_models_api_config Table

表信息 SpDevelop

ms_models_api_config 模型API配置

ms_models_api_config

属于模块:MapBoard

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | VarChar(50) | 是 | 否 |  |  |
普通字段 http_type | 请求方式 | VarChar(50) | 否 | 是 |  |  | get post put delete
普通字段 url | url | VarChar(50) | 否 | 是 |  |  |
普通字段 key1 | 参数1 | VarChar(50) | 否 | 是 |  |  |
普通字段 value1 | 参数1值 | VarChar(50) | 否 | 是 |  |  |
普通字段 key2 | 参数2 | VarChar(50) | 否 | 是 |  |  |
普通字段 value2 | 参数2值 | VarChar(50) | 否 | 是 |  |  |
普通字段 key3 | 参数3 | VarChar(50) | 否 | 是 |  |  |
普通字段 value3 | 参数3值 | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


ms_radar_target Table

表信息 SpDevelop

ms_radar_target 雷达目标信息格式

ms_radar_target

属于模块:TargetInfos

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(50) | 是 | 否 |  |  |
普通字段 device_id | 设备ID | VarChar(50) | 否 | 否 |  |  |
普通字段 device_owner_id | 设备所属站点ID | Integer | 否 | 否 |  |  |
普通字段 target_id | 目标批号 | Integer | 否 | 否 |  |  | 原则上不能重复
普通字段 counter | 目标消息 | Integer | 否 | 否 |  |  | 从0开始的计数，从发现目标后每轮周期加1，等同于该目标的跟踪时间，精度为1
普通字段 timeout_to_next | 超时等待时间 | Integer | 否 | 是 |  |  | 通常为2个天线周扫时长，精度为1ms
普通字段 status | 目标状态 | Integer | 否 | 是 |  |  | // = 0 无效/异常 // = 1 正常 // = 2 预测 // = 3 丢失
普通字段 type | 目标类型 | Integer | 否 | 是 |  |  | //0x01 – 常规目标 //0x02 – 固定/静态目标 //0x04 – 陆地 //0x08 – 其它
普通字段 speed | 速度 | Double | 否 | 是 |  |  | 精度为0.01节
普通字段 course | 航向 | Double | 否 | 是 |  |  | 精度为0.01度
普通字段 longitude | 经度 | Double | 否 | 是 |  |  | 精度为0.00000001度，wgs84坐标系
普通字段 latitude | 纬度 | Double | 否 | 是 |  |  | 精度为0.00000001度，wgs84坐标系
普通字段 size | 估算目标长度 | Integer | 否 | 是 |  |  | 精度1米
普通字段 time | 发送时间戳 | Timestamp | 否 | 是 |  |  | 时间为UTC，精度1毫秒

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


ms_ais_target Table

表信息 SpDevelop

ms_ais_target AIS目标信息格式

ms_ais_target

属于模块:TargetInfos

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | VarChar(50) | 是 | 否 |  |  |
普通字段 device_id | 设备ID | VarChar(50) | 否 | 否 |  |  |
普通字段 device_owner_id | 设备所属站点ID | Integer | 否 | 是 |  |  |
普通字段 aivdm |  | VarChar(255) | 否 | 是 |  |  | 原始VDM语句实时转发
普通字段 aivdo |  | VarChar(255) | 否 | 是 |  |  | 原始VDO语句实时转发
普通字段 time | 发送时间戳 | Timestamp | 否 | 是 |  |  | 时间为UTC时间，单位为毫秒

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


ms_ext_target Table

表信息 SpDevelop

ms_ext_target 其他设备的目标信息格式

ms_ext_target

属于模块:TargetInfos

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(50) | 是 | 否 |  |  |
普通字段 device_id | 设备ID | VarChar(50) | 否 | 否 |  |  |
普通字段 device_owner_id | 设备所属站点ID | Integer | 否 | 否 |  |  | 前端站、各级监控中心
普通字段 device_type | 设备类型 | Integer | 否 | 否 |  |  |
普通字段 target_id | 目标批号 | Integer | 否 | 是 |  |  |
普通字段 counter | 目标消息 | Integer | 否 | 是 |  |  | 从0开始的计数，从发现目标后每轮周期加1，等同于该目标的跟踪时间，精度为1
普通字段 timeout_to_next | 超时等待时间 | Datetime | 否 | 是 |  |  | 通常为2个天线周扫时长，精度为1ms
普通字段 status | 目标状态 | Integer | 否 | 是 |  |  | // = 0 无效/异常 // = 1 正常 // = 2 预测 // = 3 丢失
普通字段 type | 目标类型 | Integer | 否 | 是 |  |  | //0x01 – 自定义 //0x02 – 自定义 //0x04 – 自定义 //0x08 – 自定义
普通字段 speed | 速度 | Double | 否 | 是 |  |  | 精度为0.01节
普通字段 course | 航向 | Double | 否 | 是 |  |  | 精度为0.01度
普通字段 longitude | 经度 | Double | 否 | 是 |  |  | 精度为0.00000001度，wgs84坐标系
普通字段 latitude | 纬度 | Double | 否 | 是 |  |  | 纬度，精度为0.00000001度， wgs84坐标系
普通字段 timestamp | 发送时间戳 | Timestamp | 否 | 是 |  |  | 采用UTC时间，精度为1ms
普通字段 height | 高度 | Integer | 否 | 是 |  |  | 精度为1米
普通字段 heading | 艏向 | Integer | 否 | 是 |  |  | 以北为0度，顺时针360角度乘以100，精度为0.01度
普通字段 length | 目标长度 | Integer | 否 | 是 |  |  | 精度为1米
普通字段 width | 目标宽度 | Integer | 否 | 是 |  |  | 精度为1米
普通字段 remark | 备注 | VarChar(255) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


YH2Duct Table

表信息 SpDevelop

YH2Duct 优惠对应产品表

YH2Duct

属于模块:MD

[表空间] T_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 Id |  | Integer | 是 | 否 | (1,1) |  |
普通字段 YHCode |  | VarChar(50) | 否 | 是 |  |  |
普通字段 SaleCode |  | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


warn_event Table

表信息 SpDevelop

warn_event 警示事件表

warn_event

属于模块:Alarm

[表空间] ms_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(36) | 是 | 否 |  |  |
普通字段 create_by | 创建人 | VarChar(50) | 否 | 否 |  |  |
普通字段 create_time | 创建日期 | Datetime | 否 | 否 |  |  |
普通字段 update_by | 更新人 | VarChar(50) | 否 | 否 |  |  |
普通字段 update_time | 更新日期 | Datetime | 否 | 否 |  |  |
普通字段 sys_org_code | 所属部门 | VarChar(64) | 否 | 否 |  |  |
普通字段 end_time | 结束日期 | Datetime | 否 | 否 |  |  |
普通字段 event_serial_num | 事件编号 | VarChar(64) | 否 | 否 |  |  |
普通字段 event_type | 事件类型 | Integer | 否 | 否 |  |  |
普通字段 warn_type | 警示类型 | Integer | 否 | 否 |  |  |
普通字段 warn_level | 警示等级 | Integer | 否 | 否 |  |  |
普通字段 warn_content | 警示内容 | VarChar(200) | 否 | 否 |  |  |
普通字段 happen_loc | 发生地点 | VarChar(200) | 否 | 否 |  |  |
普通字段 deal_status | 处置状态 | Integer | 否 | 否 |  |  | 1-未处理，2-已处理
普通字段 deal_type | 处置类型 | Integer | 否 | 否 |  |  | 1-自动，2-人工
普通字段 deal_way | 处置方式 | Integer | 否 | 否 |  |  | 1-语音驱散，2-现场处理，3-灯光照射驱赶
普通字段 director | 负责人 | VarChar(32) | 否 | 否 |  |  |
普通字段 relate_dev_code | 联动设备编码 | VarChar(255) | 否 | 否 |  |  | 多个场景下存 string[]
普通字段 img_url | 现场照片 | VarChar(255) | 否 | 否 |  |  | 多个场景下存 string[]
普通字段 video_url | 现场录像 | VarChar(255) | 否 | 否 |  |  | 多个场景下存 string[]
普通字段 remark | 备注 | VarChar(200) | 否 | 否 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


scene Table

表信息 SpDevelop

scene 防区息表

scene

属于模块:Scene

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(36) | 是 | 否 |  |  |
普通字段 parent_scene_code | 上级场景编码 | VarChar(255) | 否 | 是 |  |  |
普通字段 scene_code | 场景编码 | VarChar(55) | 否 | 是 |  |  |
普通字段 scene_name | 场景名称 | VarChar(255) | 否 | 是 |  |  |
普通字段 scene_type | 场景类型 | Integer | 否 | 是 |  |  | 1:区域 2:站点
普通字段 lon | 中心经度 | Double | 否 | 是 |  |  |
普通字段 lat | 中心纬度 | Double | 否 | 是 |  |  |
普通字段 altitude | 中心海拔高度 | Double | 否 | 是 |  |  |
普通字段 rotation_x | 相机角度x | Double | 否 | 是 |  |  |
普通字段 rotation_y | 相机角度y | Double | 否 | 是 |  |  |
普通字段 rotation_z | 相机角度z | Double | 否 | 是 |  |  |
普通字段 view_distance | 距离目标多少停下 | Double | 否 | 是 |  |  |
普通字段 duration | 飞行持续时间（秒） | Integer | 否 | 是 |  |  |
普通字段 remark | 备注 | VarChar(255) | 否 | 是 |  |  |
普通字段 r_default1 | 备注1 | VarChar(255) | 否 | 是 |  |  |
普通字段 r_default2 | 备注2 | VarChar(255) | 否 | 是 |  |  |
普通字段 map_ico | 地图显示图标 | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


deveice_protocol_type Table

表信息 SpDevelop

deveice_protocol_type 设备通讯协议表

deveice_protocol_type

属于模块:DeviceManger

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | VarChar(50) | 是 | 否 |  |  |
普通字段 protocol_type | 协议类型编号 | Integer | 否 | 是 |  |  |
普通字段 protocol_name | 协议名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 remark |  | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


MD.db Module

模块信息 SpDevelop

MD.db

表

表名 | 中文表名
Basekey | 基础设置表
CodeValue |
KeyValue |
TabKeyName | 字段名定义
TabContactPerson | 联系人
Base_Area | 区域定义
CarBrand | 品牌
CarModels | 车型
Country | 国家
Servers | 服务器管理
YH2Duct | 优惠对应产品表
TabPageNumber | 基础计数表
system_config | 系统配置表

视图

视图名 中文视图名

外部表

表名 中文表名 所属模块


ms_models_board_api Table

表信息 SpDevelop

ms_models_board_api 看板模板API

ms_models_board_api

属于模块:MapBoard

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | VarChar(50) | 是 | 否 |  |  |
普通字段 board_type | 看板类型 | VarChar(50) | 否 | 是 |  |  |
普通字段 board_name | 看板类型名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 template | 模板 | Text | 否 | 是 |  |  |
普通字段 dataapi | 数据api | VarChar(150) | 否 | 是 |  |  |
普通字段 data_key | 参数key | VarChar(50) | 否 | 是 |  |  |
普通字段 testjson | 测试json | Text | 否 | 是 |  |  |
普通字段 serveapi | 服务API | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


TabPageNumber Table

表信息 SpDevelop

TabPageNumber 基础计数表

TabPageNumber

属于模块:MD

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 Id |  | Integer | 是 | 否 | (1,1) |  |
普通字段 PageNo |  | VarChar(50) | 否 | 是 |  |  |
普通字段 Number |  | Integer | 否 | 是 |  |  |
普通字段 Remark |  | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


camera_linkage Table

表信息 SpDevelop

camera_linkage 相机联动信息配置表

camera_linkage

属于模块:DeviceManger

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(36) | 是 | 否 |  |  |
普通字段 linkage_code | 联动编号 | VarChar(64) | 否 | 否 |  |  |
普通字段 cycles_number | 循环次数 | Integer | 否 | 否 |  | 1 | 循环次数默认1
普通字段 remark | 备注 | VarChar(64) | 否 | 否 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


union_target Table

表信息 SpDevelop

union_target 融合目标信息格式

union_target

属于模块:Interface

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 device_owner_id | 设备所属站点ID | VarChar(50) | 是 | 否 |  |  | 前端站、各级监控中心
普通字段 display_id | 目标批号 | Integer | 否 | 否 |  |  | 原则上不能重复
普通字段 mmsi | Mmsi号 | Integer | 否 | 否 |  |  |
普通字段 status | 目标状态 | Integer | 否 | 否 |  |  | // = 1 正常 // = 2 预测 // = 3 丢失
普通字段 geo_ptn | 经纬度 | VarChar(255) | 否 | 否 |  |  | double latitude = 1; //纬度 double longitude = 2; //经度 wgs84坐标系，精度为0.00000001度
普通字段 course | 航向 | Double | 否 | 否 |  |  | 精度为0.01度
普通字段 speed | 速度 | Double | 否 | 否 |  |  | 精度为0.01节
普通字段 heading | 艏向 | Double | 否 | 否 |  |  | 精度为0.01度
普通字段 length | 估算目标长度 | Double | 否 | 否 |  |  | 精度为1米
普通字段 wid | 估算目标宽度 | Integer | 否 | 否 |  |  | 精度为1米
普通字段 shiptype | AIS船舶类型 | Integer | 否 | 否 |  |  | AIS船舶类型
普通字段 sclass | 枚举船舶类型 | VarChar(255) | 否 | 否 |  |  | AIS_A=0; //AIS A类型 AIS_B=1; //AIS B类型 RADAR=2; //雷达类型 SIM=3; //模拟目标类型 NORMAL_AIS_A_RADAR=4; //正常AIS A目标和雷达目标融合后的类型 NORMAL_AIS_B_RADAR=5; //正常AIS B目标和雷达目标融合后的类型 LOST_AIS_A_RADAR=6; //AIS A信号丢失的目标和雷达目标融合后的类型 LOST_AIS_B_RADAR=7; //AIS B信号丢失的目标和雷达目标融合后的类型 SIM_RADAR=8; //模拟目标和雷达目标融合后的类型 AID=9; //助航物类型 STATIC=10; //静态目标类型
普通字段 vessel_name | 船名 | VarChar(255) | 否 | 否 |  |  |
普通字段 vendor_id | 建造方ID | VarChar(255) | 否 | 否 |  |  |
普通字段 call_sign | 呼号 | VarChar(255) | 否 | 否 |  |  |
普通字段 imo | IMO | Integer | 否 | 否 |  |  |
普通字段 last_tm | 目标从服务器发送时间 | Datetime | 否 | 否 |  |  |
普通字段 ais_ext_infos | AisExt | VarChar(255) | 否 | 否 |  |  |
普通字段 src_num | 融合来源个数 | Integer | 否 | 否 |  |  | 融合来源个数
普通字段 src_index | 来源索引 | Integer | 否 | 否 |  |  |
普通字段 src_type | 来源类型 | Integer | 否 | 否 |  |  | 1-雷达，2-AIS，3-融合，4-北斗，5-GPS，6-其它
普通字段 src_site_id | 目标来源设备的所属站点ID | VarChar(255) | 否 | 否 |  |  | 目标来源设备的所属站点ID
普通字段 src_device_id | 目标来源设备的ID | VarChar(255) | 否 | 否 |  |  |
普通字段 Src_target_key | 目标来源ais时为mmsi | VarChar(255) | 否 | 否 |  |  | 雷达时为批号，融合时为新的ID号...

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


ms_ais_info Table

表信息 SpDevelop

ms_ais_info AIS信息表

ms_ais_info

属于模块:TargetInfos

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(36) | 是 | 否 |  |  |
普通字段 create_by | 创建人 | VarChar(50) | 否 | 否 |  |  |
普通字段 create_time | 创建日期 | Datetime | 否 | 否 |  |  |
普通字段 update_by | 更新人 | VarChar(50) | 否 | 否 |  |  |
普通字段 update_time | 更新日期 | Datetime | 否 | 否 |  |  |
普通字段 event_serial_num | 事件编号 | VarChar(64) | 否 | 是 |  |  |
普通字段 ship_name | 船名 | VarChar(100) | 否 | 否 |  |  |
普通字段 mmsi | MMSI | VarChar(64) | 否 | 否 |  |  |
普通字段 call_sign | 呼号 | VarChar(64) | 否 | 否 |  |  |
普通字段 imo | IMO | VarChar(64) | 否 | 否 |  |  |
普通字段 bow_direction | 船首向 | Decimal(17,14) | 否 | 否 |  |  |
普通字段 track_direction | 航迹向 | Decimal(17,14) | 否 | 否 |  |  |
普通字段 ship_status | 状态 | Integer | 否 | 否 |  | 99 |
普通字段 ship_length | 船长 | Double | 否 | 否 |  | 0 |
普通字段 ship_width | 船宽 | Double | 否 | 否 |  | 0 |
普通字段 draft | 吃水 | Double | 否 | 否 |  | 0 |
普通字段 ship_type | 类型 | Integer | 否 | 否 |  | 90 |
普通字段 ship_speed | 航速 | Double | 否 | 否 |  | 0 |
普通字段 destination | 目的地 | VarChar(36) | 否 | 否 |  |  |
普通字段 longitude | 经度 | Decimal(17,14) | 否 | 否 |  |  |
普通字段 latitude | 纬度 | Decimal(17,14) | 否 | 否 |  |  |
普通字段 nationality | 国籍 | VarChar(32) | 否 | 否 |  |  |
普通字段 pre_arrival_time | 预到时间 | Datetime | 否 | 否 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


monitor_model_linkage Table

表信息 SpDevelop

monitor_model_linkage 监控联动表

monitor_model_linkage

属于模块:AI

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | VarChar(50) | 是 | 否 |  |  |
普通字段 linkage_type | 联动类型 | Integer | 否 | 是 |  |  | 1：视频 2：待定 3：待定
普通字段 model_id | 监控模型id | VarChar(50) | 否 | 是 |  |  |
普通字段 linkage_id | 联动Id | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


Base_Area Table

表信息 SpDevelop

Base_Area 区域定义

Base_Area

属于模块:MD

[表空间] Base_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | Integer | 是 | 否 | (1,1) |  |
普通字段 AreaId |  | VarChar(50) | 否 | 否 |  |  |
普通字段 PAreaId | pID | VarChar(50) | 否 | 是 |  |  |
普通字段 AreaCode | 国标编号 | VarChar(50) | 否 | 是 |  |  |
普通字段 AreaName | 区域名称 | VarChar(100) | 否 | 是 |  |  |
普通字段 MangerMan | 负责人 | VarChar(20) | 否 | 是 |  |  |
普通字段 IsCity |  | Integer | 否 | 是 |  |  |
普通字段 HaseSub | 下一级数量 | Integer | 否 | 是 |  | 0 |
普通字段 Level | 级别 | Integer | 否 | 是 |  |  |
普通字段 OrderChart |  | VarChar(10) | 否 | 是 |  |  |
普通字段 QuickQuery | 全拼 | VarChar(50) | 否 | 是 |  |  |
普通字段 SimpleSpelling | 简拼 | VarChar(50) | 否 | 是 |  |  |
普通字段 AreaType | 区域类别 | Integer | 否 | 是 |  |  | 0:国家 1：省市 2：市
普通字段 HaveOver | 覆盖 | Integer | 否 | 是 |  |  |
普通字段 Default1 |  | VarChar(50) | 否 | 是 |  |  |
普通字段 Default2 |  | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


MapBoard.db Module

模块信息 SpDevelop

MapBoard.db

表

表名 | 中文表名
ms_models_board | 看板模板
ms_models_api_config | 模型API配置
ms_models_board_api | 看板模板API
ms_rpt_data_head | 看板数据主表

视图

视图名 中文视图名

外部表

表名 中文表名 所属模块


CarBrand Table

表信息 SpDevelop

CarBrand 品牌

CarBrand

属于模块:MD

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 Id |  | Integer | 是 | 否 | (1,1) |  |
普通字段 Brand | 品牌 | VarChar(50) | 否 | 是 |  |  |
普通字段 imgpath | 图片路径 | VarChar(50) | 否 | 是 |  |  |
普通字段 GroupBy | 分组 | VarChar(50) | 否 | 是 |  |  |
普通字段 Default1 |  | VarChar(50) | 否 | 是 |  |  |
普通字段 OrderBy |  | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


iot.db Module

模块信息 SpDevelop

iot.db

表

表名 | 中文表名
node_info | 设备表

视图

视图名 中文视图名

外部表

表名 中文表名 所属模块


ai_model_type Table

表信息 SpDevelop

ai_model_type 视频智能监控模型分类

ai_model_type

属于模块:AI

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | VarChar(50) | 是 | 否 |  |  |
普通字段 model_code | 模型编号 | VarChar(50) | 否 | 是 |  |  |
普通字段 model_name | 模型名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 remark | 备注 | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


map_draw Table

表信息 SpDevelop

map_draw 地图画图

map_draw

属于模块:ThreeDMap

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(50) | 是 | 否 |  |  |
普通字段 scene_id | 场景Id | VarChar(50) | 否 | 是 |  |  |
普通字段 draw_type | 画图类型 | Integer | 否 | 是 |  |  | 0：一般 1：军事态势标会
普通字段 draw_data | 画图数据 | Text | 否 | 是 |  |  |
普通字段 remark | 备注 | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


Scene.db Module

模块信息 SpDevelop

Scene.db

表

表名 | 中文表名
scene | 防区息表

视图

视图名 中文视图名

外部表

表名 中文表名 所属模块


Servers Table

表信息 SpDevelop

Servers 服务器管理

Servers

属于模块:MD

[表空间] T_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 Id |  | Integer | 是 | 否 | (1,1) |  |
普通字段 SvrId | 服务器编号 | VarChar(20) | 否 | 是 |  |  | S:socket 服务器S001 W：web服务器 D：数据库服务器
普通字段 SvrIP | 服务器名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 Remark | 功能描述 | VarChar(150) | 否 | 是 |  |  |
普通字段 Default1 |  | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


intelligence_info Table

表信息 SpDevelop

intelligence_info 情报信息

intelligence_info

属于模块:aaaaaa

[表空间] jc_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | 主键 | VarChar(36) | 是 | 否 |  |  |
普通字段 number | 情报编号 | VarChar(32) | 否 | 是 |  |  |
普通字段 report_time | 情报发生时间 | Datetime | 否 | 是 |  |  |
普通字段 content | 情报内容 | Text | 否 | 是 |  |  |
普通字段 desc | 情报描述 | VarChar(32) | 否 | 是 |  |  |
普通字段 origin | 情报来源 | VarChar(32) | 否 | 是 |  |  |
普通字段 type_id | 情报分类id | VarChar(32) | 否 | 是 |  |  |
普通字段 type_name | 情报分类名称 | VarChar(32) | 否 | 是 |  |  |
普通字段 level_id | 情报分级id | VarChar(32) | 否 | 是 |  |  |
普通字段 level_name | 情报分级名称 | VarChar(32) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


ai_models Table

表信息 SpDevelop

ai_models 视频智能监控模型

ai_models

属于模块:AI

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | VarChar(50) | 是 | 否 |  |  |
普通字段 model_code | 模型编号 | VarChar(50) | 否 | 是 |  |  |
普通字段 model_name | 模型名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 remark | 备注 | VarChar(50) | 否 | 是 |  |  |
普通字段 area_data | 模型范围数据 | Text | 否 | 是 |  |  |
普通字段 camera_id | 相机id | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


TargetInfos.db Module

模块信息 SpDevelop

TargetInfos.db

表

表名 | 中文表名
ms_union_target | 融合目标信息格式
ms_ext_target | 其他设备的目标信息格式
ms_ais_target | AIS目标信息格式
ms_radar_target | 雷达目标信息格式
ms_ais_info | AIS信息表
camera_screenshots | 相机抓拍图片（手动）

视图

视图名 中文视图名

外部表

表名 中文表名 所属模块


event_type Table

表信息 SpDevelop

event_type 事件类型

event_type

属于模块:aaaaaa

[表空间] jc_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | 主键 | VarChar(36) | 是 | 否 |  |  |
普通字段 type_name | 分类名字 | VarChar(255) | 否 | 是 |  |  |
普通字段 type_code | 分类编码 | VarChar(255) | 否 | 是 |  |  |
普通字段 type_desc | 分类描述 | VarChar(255) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


device_sensor_info Table

表信息 SpDevelop

device_sensor_info 设备传感器表

device_sensor_info

属于模块:DeviceManger

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(50) | 是 | 否 |  |  |
普通字段 deveice_id | 设备id | VarChar(50) | 否 | 是 |  |  |
普通字段 sensor_name | 传感器名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 sensor_code | 传感器编号 | VarChar(50) | 否 | 是 |  |  |
普通字段 sensor_status | 状态 | Integer | 否 | 是 |  |  |
普通字段 sensor_lon | 经度 | Double | 否 | 是 |  |  |
普通字段 sensor_lat | 维度 | Double | 否 | 是 |  |  |
普通字段 sensor_address | 地址编号例如01 | VarChar(50) | 否 | 是 |  |  |
普通字段 port_id | 寄存器地址编号 | Integer | 否 | 是 |  |  |
普通字段 sdata | 值 | Double | 否 | 是 |  |  |
普通字段 remark | 备注 | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


intelligence_level Table

表信息 SpDevelop

intelligence_level 情报等级

intelligence_level

属于模块:aaaaaa

[表空间] jc_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | 主键 | VarChar(36) | 是 | 否 |  |  |
普通字段 level_name | 分级名字 | VarChar(255) | 否 | 是 |  |  |
普通字段 level_code | 分级编码 | VarChar(255) | 否 | 是 |  |  |
普通字段 level_principle | 分级原则 | VarChar(255) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


alarm_info Table

表信息 SpDevelop

alarm_info 告警信息格式

alarm_info

属于模块:Interface

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 alarm_id | 报警信息唯一标识 | VarChar(50) | 是 | 否 |  |  | 32位随机字符串
普通字段 alarm_owner_id | 报警所属站点ID | Integer | 否 | 否 |  |  | 前端站、各级监控中心
普通字段 alarm_type | 报警类型 | Integer | 否 | 否 |  |  | 1：雷达报警，2：人工报警；3：传感器报警；4：光电报警； 11：首次进入预警；12：双拖预警； 13：单拖预警；14：多个AIS预警； 15：AIS变更预警；16：异常轨迹预警； 17：禁入预警；18：航道偏离预警； 19：黑名单预警；20：非法驻留预警 21：低速并靠预警；22：低速行驶预警； 23：超速行驶预警；24：大飞预警； 25：AIS关闭预警；26：航向错误预警； 27：非法采砂预警；28：非法搭靠预警； 29：非法抛锚预警；
普通字段 alarm_type_name | 报警类型名称 | VarChar(255) | 否 | 否 |  |  | 1：雷达报警，2：人工报警；3：传感器报警；4：光电报警；
普通字段 alarm_level | 报警等级 | Integer | 否 | 否 |  |  | 1：危急；2：紧急（高）；3：警告（中）；4：一般（低）；5：未知
普通字段 alarm_content | 报警信息描述 | VarChar(255) | 否 | 否 |  |  |
普通字段 alarm_disposal | 报警处置状态 | VarChar(255) | 否 | 否 |  |  | 0：未处置，1：已处置，2：处置中，3：已取消
普通字段 alarm_time_start | 报警开始时间 | Datetime | 否 | 否 |  |  |
普通字段 alarm_time_end | 报警关闭时间 | Datetime | 否 | 否 |  |  |
普通字段 alarm_point_lon | 报警点经度 | Double | 否 | 否 |  |  | 小数点后6位，113.337664
普通字段 alarm_point_lat | 报警点纬度 | Double | 否 | 否 |  |  | 小数点后6位，22.597240
普通字段 alarm_point_alt | 报警点海拔 | Double | 否 | 否 |  |  | 小数点后2位，71.45；
普通字段 alarm_target_id | 关联报警目标唯一标识 | VarChar(255) | 否 | 否 |  |  | 32位随机字符串
普通字段 target_point | 记录目标到目前位置航迹点位 | VarChar(255) | 否 | 否 |  |  |
普通字段 alarm_camera_id | 关联摄像机唯一标识 | VarChar(255) | 否 | 否 |  |  | 可以关联多个摄像机镜头

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


Basekey Table

表信息 SpDevelop

Basekey 基础设置表

Basekey

属于模块:MD

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 Id |  | Integer | 是 | 否 | (1,1) |  |
普通字段 BaseKey |  | VarChar(50) | 否 | 是 |  |  |
普通字段 BaseName |  | VarChar(50) | 否 | 是 |  |  |
普通字段 XFlag |  | Integer | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


Alarm.db Module

模块信息 SpDevelop

Alarm.db

表

表名 | 中文表名
ms_alarm_info | 告警信息格式
warn_event | 警示事件表
warn_level | 报警等级表

视图

视图名 中文视图名

外部表

表名 中文表名 所属模块


monitor_model_type Table

表信息 SpDevelop

monitor_model_type 综合监控模型分类

monitor_model_type

属于模块:AI

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | VarChar(50) | 是 | 否 |  |  |
普通字段 model_code | 模型编号 | VarChar(50) | 否 | 是 |  |  |
普通字段 model_name | 模型名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 remark | 备注 | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


JointControl.db Module

模块信息 SpDevelop

JointControl.db

表

表名 | 中文表名
intelligence_info | 情报信息
intelligence_type | 情报类型
intelligence_level | 情报等级
event_info | 事件信息
event_type | 事件类型
event_level | 事件等级

视图

视图名 中文视图名

外部表

表名 中文表名 所属模块


TabKeyName Table

表信息 SpDevelop

TabKeyName 字段名定义

TabKeyName

属于模块:MD

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 Id |  | Integer | 是 | 否 | (1,1) |  |
普通字段 Typeid | 类别id | Integer | 否 | 是 |  |  |
普通字段 FrmName | 窗体名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 ValueName | 字段名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 Remark |  | VarChar(50) | 否 | 是 |  |  |
普通字段 XFlag |  | Integer | 否 | 是 |  |  | 0: tabKeyValue 表 1: tabCodeValue 表

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


device_status Table

表信息 SpDevelop

device_status 设备状态信息

device_status

属于模块:DeviceManger

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(50) | 是 | 否 |  |  |
普通字段 device_id | 设备唯一标识 | VarChar(50) | 否 | 是 |  |  | 32位随机字符串
普通字段 device_owner_id | 设备所属站点ID | Integer | 否 | 否 |  |  | 前端站、各级监控中心
普通字段 status | 设备初始状态 | Integer | 否 | 否 |  |  | 0：在线，正常工作；1：离线，设备关机；2：在线，设备故障；3，其它
普通字段 remark | 状态补充说明 | VarChar(255) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


Interface.db Module

模块信息 SpDevelop

Interface.db

表

表名 | 中文表名
alarm_info | 告警信息格式
union_target | 融合目标信息格式
ext_target | 其他设备的目标信息格式
ais_target | AIS目标信息格式
radar_target | 雷达目标信息格式

视图

视图名 中文视图名

外部表

表名 中文表名 所属模块


warn_level Table

表信息 SpDevelop

warn_level 报警等级表

warn_level

属于模块:Alarm

[表空间] ms_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(36) | 是 | 否 |  |  |
普通字段 create_by | 创建人 | VarChar(50) | 否 | 否 |  |  |
普通字段 create_time | 创建日期 | Datetime | 否 | 否 |  |  |
普通字段 update_by | 更新人 | VarChar(50) | 否 | 否 |  |  |
普通字段 update_time | 更新日期 | Datetime | 否 | 否 |  |  |
普通字段 sys_org_code | 所属部门 | VarChar(64) | 否 | 否 |  |  |
普通字段 line_id | 区域编号 | VarChar(36) | 否 | 否 |  |  |
普通字段 warn_type | 报警类型 | Integer | 否 | 否 |  |  |
普通字段 warn_level | 报警级别 | Integer | 否 | 否 |  |  |
普通字段 warn_audio | 音频文件路径 | VarChar(255) | 否 | 否 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


KeyValue Table

表信息 SpDevelop

KeyValue

KeyValue

属于模块:MD

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 Id |  | Integer | 是 | 否 | (1,1) |  |
普通字段 TypeID |  | Integer | 否 | 是 |  |  |
普通字段 KeyId |  | Integer | 否 | 是 |  |  |
普通字段 KeyValue |  | VarChar(50) | 否 | 是 |  |  |
普通字段 Remark |  | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


camera_linkage_sub Table

表信息 SpDevelop

camera_linkage_sub 相机联动信息配置子表

camera_linkage_sub

属于模块:DeviceManger

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(36) | 是 | 否 |  |  |
普通字段 linkage_id | 联动id | VarChar(64) | 否 | 否 |  |  |
普通字段 linkage_type | 联动类型 | Integer | 否 | 是 |  |  | 1;ptz 2:预置位 3：其他
普通字段 linkage_no | 序号 | Integer | 否 | 是 |  |  |
普通字段 camera_id | 相机编号 | VarChar(64) | 否 | 否 |  |  |
普通字段 ptz | PTZ值 | VarChar(200) | 否 | 否 |  |  |
普通字段 placements | 预置位 | VarChar(64) | 否 | 否 |  |  |
普通字段 sleep_number | 停留时间 | Integer | 否 | 否 |  |  | 毫秒

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


Country Table

表信息 SpDevelop

Country 国家

Country

属于模块:MD

[表空间] T_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 Id |  | Integer | 是 | 否 | (1,1) |  |
普通字段 CountryId | 国家id | Integer | 否 | 是 |  |  |
普通字段 CountryName | 国家名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 ImgPath | 国旗 | VarChar(60) | 否 | 是 |  |  |
普通字段 Remark |  | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


ms_alarm_info Table

表信息 SpDevelop

ms_alarm_info 告警信息格式

ms_alarm_info

属于模块:Alarm

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | 报警信息唯一标识 | VarChar(50) | 是 | 否 |  |  | 32位随机字符串
普通字段 target_id | 目标id | VarChar(50) | 否 | 是 |  |  |
普通字段 alarm_owner_id | 报警所属站点ID | Integer | 否 | 否 |  |  | 前端站、各级监控中心
普通字段 alarm_type | 报警类型 | Integer | 否 | 否 |  |  | 1：雷达报警，2：人工报警；3：传感器报警；4：光电报警； 11：首次进入预警；12：双拖预警； 13：单拖预警；14：多个AIS预警； 15：AIS变更预警；16：异常轨迹预警； 17：禁入预警；18：航道偏离预警； 19：黑名单预警；20：非法驻留预警 21：低速并靠预警；22：低速行驶预警； 23：超速行驶预警；24：大飞预警； 25：AIS关闭预警；26：航向错误预警； 27：非法采砂预警；28：非法搭靠预警； 29：非法抛锚预警；
普通字段 alarm_type_name | 报警类型名称 | VarChar(255) | 否 | 否 |  |  | 1：雷达报警，2：人工报警；3：传感器报警；4：光电报警；
普通字段 alarm_level | 报警等级 | Integer | 否 | 否 |  |  | 1：危急；2：紧急（高）；3：警告（中）；4：一般（低）；5：未知
普通字段 alarm_content | 报警信息描述 | VarChar(255) | 否 | 是 |  |  |
普通字段 alarm_disposal | 报警处置状态 | VarChar(255) | 否 | 是 |  |  | 0：未处置，1：已处置，2：处置中，3：已取消
普通字段 alarm_time_start | 报警开始时间 | Datetime | 否 | 是 |  |  |
普通字段 alarm_time_end | 报警关闭时间 | Datetime | 否 | 否 |  |  |
普通字段 alarm_point_lon | 报警点经度 | Double | 否 | 是 |  | 0 | 小数点后6位，113.337664
普通字段 alarm_point_lat | 报警点纬度 | Double | 否 | 是 |  | 0 | 小数点后6位，22.597240
普通字段 alarm_point_alt | 报警点海拔 | Double | 否 | 是 |  | 0 | 小数点后2位，71.45；
普通字段 alarm_target_id | 关联报警目标唯一标识 | VarChar(255) | 否 | 是 |  |  | 32位随机字符串
普通字段 target_point | 记录目标到目前位置航迹点位 | VarChar(255) | 否 | 是 |  |  |
普通字段 alarm_camera_id | 关联摄像机唯一标识 | VarChar(255) | 否 | 是 |  |  | 可以关联多个摄像机镜头

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


event_info Table

表信息 SpDevelop

event_info 事件信息

event_info

属于模块:aaaaaa

[表空间] jc_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | 主键 | VarChar(36) | 是 | 否 |  |  |
普通字段 number | 事件编号 | VarChar(32) | 否 | 是 |  |  |
普通字段 occur_time | 事件发生时间 | Datetime | 否 | 是 |  |  |
普通字段 content | 事件内容 | VarChar(255) | 否 | 是 |  |  |
普通字段 desc | 事件描述 | VarChar(32) | 否 | 是 |  |  |
普通字段 location | 事件位置 | VarChar(64) | 否 | 是 |  |  |
普通字段 longitude | 事件经度 | Decimal(11,8) | 否 | 是 |  |  |
普通字段 latitude | 事件纬度 | Decimal(10,8) | 否 | 是 |  |  |
普通字段 altitude | 事件高度 | Decimal(7,6) | 否 | 是 |  |  |
普通字段 type_id | 事件分类id | VarChar(32) | 否 | 是 |  |  |
普通字段 type_name | 事件分类名称 | VarChar(32) | 否 | 是 |  |  |
普通字段 level_id | 事件分级id | VarChar(32) | 否 | 是 |  |  |
普通字段 level_name | 事件分级名称 | VarChar(32) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


camera_setting Table

表信息 SpDevelop

camera_setting 相机信息表

camera_setting

属于模块:DeviceManger

[表空间] ms_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(36) | 是 | 否 |  |  |
普通字段 create_by | 创建人 | VarChar(50) | 否 | 否 |  |  |
普通字段 create_time | 创建日期 | Datetime | 否 | 否 |  |  |
普通字段 update_by | 更新人 | VarChar(50) | 否 | 否 |  |  |
普通字段 update_time | 更新日期 | Datetime | 否 | 否 |  |  |
普通字段 site_id | 站点id | VarChar(36) | 否 | 否 |  |  |
普通字段 site_name | 站点名称 | VarChar(32) | 否 | 否 |  |  |
普通字段 ip | 相机ip | VarChar(20) | 否 | 否 |  |  |
普通字段 ip2 | 相机备用ip | VarChar(20) | 否 | 否 |  |  |
普通字段 port | 端口 | Integer | 否 | 否 |  |  |
普通字段 user | 认证用户名 | VarChar(32) | 否 | 否 |  |  |
普通字段 password | 认证密码 | VarChar(32) | 否 | 否 |  |  |
普通字段 channel | 相机预览通道 | Integer | 否 | 否 |  |  |
普通字段 pre_rtsp | rtsp地址 | VarChar(200) | 否 | 否 |  |  |
普通字段 analysis_rtsp | 分析rtsp | VarChar(200) | 否 | 否 |  |  |
普通字段 record_rtsp | 录像rtsp | VarChar(200) | 否 | 否 |  |  |
普通字段 cloud_ctrl_ip | 云台控制ip | VarChar(32) | 否 | 否 |  |  |
普通字段 cloud_ctrl_port | 云台控制端口 | Integer | 否 | 否 |  |  |
普通字段 camera_name | 相机名称 | VarChar(32) | 否 | 否 |  |  |
普通字段 camera_code | 相机编号 | VarChar(100) | 否 | 否 |  |  |
普通字段 longitude | 经度 | Decimal(17,14) | 否 | 否 |  |  |
普通字段 latitude | 纬度 | Decimal(17,14) | 否 | 否 |  |  |
普通字段 type | 类型 | Integer | 否 | 否 |  |  |
普通字段 style | 样式 | Integer | 否 | 否 |  |  |
普通字段 left_angle | 左夹角 | Double | 否 | 否 |  |  |
普通字段 right_angle | 右夹角 | Double | 否 | 否 |  |  |
普通字段 view_distance | 视野中央有效距离 | Double | 否 | 否 |  |  |
普通字段 frame_rate | 采样帧率 | Integer | 否 | 否 |  |  |
普通字段 max_range | 最大跟踪范围 | Integer | 否 | 否 |  |  |
普通字段 factory | 相机类型 | Integer | 否 | 否 |  |  |
普通字段 status | 状态 | Integer | 否 | 否 |  |  |
普通字段 max_visible_distance | 最大可视距离 | Double | 否 | 否 |  |  |
普通字段 zoom_factor | 变焦因子 | Double | 否 | 否 |  |  |
普通字段 zero_azimuth | 零方位角（正北夹角） | Double | 否 | 否 |  |  |
普通字段 fixed_angle | 安装垂直角（上下-90°~90°） | Double | 否 | 否 |  |  |
普通字段 streaming_media_id | 流媒体服务器id | VarChar(36) | 否 | 否 |  |  |
普通字段 video_recorder_id | 录像机id | VarChar(36) | 否 | 否 |  |  |
普通字段 height | 高度 | Decimal(17,10) | 否 | 否 |  |  |
普通字段 max_elevation | 最大仰角 | Double | 否 | 否 |  |  |
普通字段 day_begin_time | 白光开始时间 | VarChar(10) | 否 | 否 |  |  |
普通字段 day_end_time | 白光结束时间 | VarChar(10) | 否 | 否 |  |  |
普通字段 alarm_num | 报警持续时间 | Integer | 否 | 否 |  | 0 |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


ms_rpt_data_head Table

表信息 SpDevelop

ms_rpt_data_head 看板数据主表

ms_rpt_data_head

属于模块:MapBoard

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | VarChar(50) | 是 | 否 |  |  |
普通字段 board_code | 看板编号 | VarChar(50) | 否 | 是 |  |  |
普通字段 board_name | 看板名称 | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


system_config Table

表信息 SpDevelop

system_config 系统配置表

system_config

属于模块:MD

[表空间] ms_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id | id | VarChar(50) | 是 | 否 |  |  |
普通字段 types | 前端后端 | Integer | 否 | 是 |  | 0 | 0:后端 1:前端
普通字段 key_id | 主键 | VarChar(50) | 否 | 是 |  |  |
普通字段 key_value | 键值 | VarChar(50) | 否 | 是 |  |  |
普通字段 remark | 备注 | VarChar(100) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


ms_models_board Table

表信息 SpDevelop

ms_models_board 看板模板

ms_models_board

属于模块:MapBoard

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | VarChar(50) | 是 | 否 |  |  |
普通字段 board_type | 看板类型 | VarChar(50) | 否 | 是 |  |  |
普通字段 board_name | 看板名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 template | 模板 | Text | 否 | 是 |  |  |
普通字段 dataurl | 数据url | VarChar(150) | 否 | 是 |  |  |
普通字段 data_key | 参数key | VarChar(50) | 否 | 是 |  |  |
普通字段 testjson | 测试json | Text | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


ext_target Table

表信息 SpDevelop

ext_target 其他设备的目标信息格式

ext_target

属于模块:Interface

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 device_id | 设备ID | VarChar(50) | 是 | 否 |  |  |
普通字段 device_owner_id | 设备所属站点ID | Integer | 否 | 否 |  |  | 前端站、各级监控中心
普通字段 device_type | 设备类型 | Integer | 否 | 否 |  |  |
普通字段 id | 目标批号 | Integer | 否 | 否 |  |  |
普通字段 counter | 目标消息 | Integer | 否 | 否 |  |  | 从0开始的计数，从发现目标后每轮周期加1，等同于该目标的跟踪时间，精度为1
普通字段 timeout_to_next | 超时等待时间 | Datetime | 否 | 否 |  |  | 通常为2个天线周扫时长，精度为1ms
普通字段 status | 目标状态 | Integer | 否 | 否 |  |  | // = 0 无效/异常 // = 1 正常 // = 2 预测 // = 3 丢失
普通字段 type | 目标类型 | Integer | 否 | 否 |  |  | //0x01 – 自定义 //0x02 – 自定义 //0x04 – 自定义 //0x08 – 自定义
普通字段 speed | 速度 | Double | 否 | 否 |  |  | 精度为0.01节
普通字段 course | 航向 | Double | 否 | 否 |  |  | 精度为0.01度
普通字段 longitude | 经度 | Double | 否 | 否 |  |  | 精度为0.00000001度，wgs84坐标系
普通字段 latitude | 纬度 | Double | 否 | 否 |  |  | 纬度，精度为0.00000001度， wgs84坐标系
普通字段 timestamp | 发送时间戳 | Timestamp | 否 | 否 |  |  | 采用UTC时间，精度为1ms
普通字段 height | 高度 | Integer | 否 | 是 |  |  | 精度为1米
普通字段 heading | 艏向 | Integer | 否 | 是 |  |  | 以北为0度，顺时针360角度乘以100，精度为0.01度
普通字段 length | 目标长度 | Integer | 否 | 是 |  |  | 精度为1米
普通字段 width | 目标宽度 | Integer | 否 | 是 |  |  | 精度为1米
普通字段 remark | 备注 | VarChar(255) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


CarModels Table

表信息 SpDevelop

CarModels 车型

CarModels

属于模块:MD

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 Id |  | Integer | 是 | 否 | (1,1) |  |
普通字段 BrandId | 品牌 | Integer | 否 | 是 |  |  |
普通字段 Models | 车型 | VarChar(50) | 否 | 是 |  |  |
普通字段 imgpath | 图片路径 | VarChar(50) | 否 | 是 |  |  |
普通字段 OrderBy | 排序 | VarChar(50) | 否 | 是 |  |  |
普通字段 Default1 |  | VarChar(50) | 否 | 是 |  |  |
普通字段 GroupBy |  | VarChar(50) | 否 | 是 |  |  |

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


deveice_type Table

表信息 SpDevelop

deveice_type 设备类型表

deveice_type

属于模块:DeviceManger

[表空间] dt_
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 id |  | VarChar(50) | 是 | 否 |  |  |
普通字段 type_no | 类型编号 | Integer | 否 | 是 |  |  |
普通字段 type_name | 类型名称 | VarChar(50) | 否 | 是 |  |  |
普通字段 map_ico | 地图显示图片模型 | VarChar(150) | 否 | 是 |  |  |
普通字段 is3d | 是否3D | Integer | 否 | 是 |  |  |
普通字段 width | 默认宽度 | Decimal(10,2) | 否 | 是 |  |  |
普通字段 length | 默认长度 | Decimal(10,2) | 否 | 是 |  |  |
普通字段 height | 默认高度 | Decimal(10,2) | 否 | 是 |  |  | 单位米

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容


ThreeDMap.db Module

模块信息 SpDevelop

ThreeDMap.db

表

表名 | 中文表名
map_draw | 地图画图

视图

视图名 中文视图名

外部表

表名 中文表名 所属模块


AI.db Module

模块信息 SpDevelop

AI.db

表

表名 | 中文表名
ai_model_type | 视频智能监控模型分类
monitor_model_type | 综合监控模型分类
ai_models | 视频智能监控模型
monitor_models | 综合监控模型
monitor_model_linkage | 监控联动表

视图

视图名 中文视图名

外部表

表名 中文表名 所属模块


ais_target Table

表信息 SpDevelop

ais_target AIS目标信息格式

ais_target

属于模块:Interface

[表空间]
[表所有者]
[备注]

字段

字段名 | 中文列名 | 类型 | PK | 空值 | 自动增长 | 默认值 | 注释
关键字段 device_id | 设备ID | VarChar(50) | 是 | 否 |  |  |
普通字段 device_owner_id | 设备所属站点ID | Integer | 否 | 否 |  |  |
普通字段 aivdm |  | VarChar(255) | 否 | 否 |  |  | 原始VDM语句实时转发
普通字段 aivdo |  | VarChar(255) | 否 | 否 |  |  | 原始VDO语句实时转发
普通字段 time | 发送时间戳 | Timestamp | 否 | 否 |  |  | 时间为UTC时间，单位为毫秒

索引

索引名 索引类型 字段 注释

约束

约束名

触发器

触发器名 内容